My Onxmaps app crashed today.

MT-ED

Newbie
Joined
Aug 9, 2020
Messages
9
I headed out for a hike this morning in and area I've been hiking for the last couple of weeks accounting for 5 different hikes. Each time, I've used the tracker function, and have had no problems. Today, however, when I fired up the app, I got the photo of two people , and it wasn't until I tapped the "back" arrow in the lower left, that it converted over to my map. I chose the tracker function and started off. The small red dot would follow my progress, but it was not plotting my track, even though it said one was being tracked. After a while, I wanted to plot a way point, and it would not plot one! I kept hiking and after a bit more time, I got a message that onxmaps was not responding, did I want to: wait, close the app, or send feedback? I tried to close it and restart. After clicking the onxmaps app icon and hearing the click, it took a good 30 seconds before anything happened, and when it did, the screen was black! After a little while, I once again got the message of: waiting, close, etc.k

The app never came back to life for the next 4 hours of my hike. When I got home, the wait,close, feedback message was still on the screen, so I chose to send feedback. After sending the feedback, i once again tried to fire up the onxmaps app, and it came to life just like every other time, accept this time, it stated that a track was being recorded, did I want to cancel it or resume it. I chose resume and it took me back to where I was hiking (not home, where I actually was). There was NO track, it acted like I was just wanting to start a hike and had just selected the tracker option.

I went to onx online for help. All they suggested was to start deleting tracks, waypoints, and anything else I had saved. Now I can understand their logic with this suggestion, but if this indeed WAS the problem, why did my app start working just fine after I got back home, and without my deleting anything that I had previously saved? I will be returning to this same area in a week or so, and I'll try it again to see if this was just a fluke or some real problem.

My question for anyone that has read this far is, have any of you had a similar experience? If so, did you find the culprit that caused it? Were you able to revive the app while out in the field, and if so, how did you do it? I welcome any suggestions or questions.....I'd really like to prevent this from happening again if at all possible. Thanks so much in advance!!
 
OP
M

MT-ED

Newbie
Joined
Aug 9, 2020
Messages
9
Thanks for your input folks! I appologize for not including this earlier, but I always use my phone in airplane mode, and it was this time as well? Perhaps I'm confused and really don't understand how onx works? I thought that I was to download my maps while "online" so they could be accessed "offline" when out in the field, without internet service? Also, when I started for the day, the only thing that was not working was the tracker function (remember the small red dot followed my travels precisely, until onx just gave up the ship). Based on these observations, the onx app was supplying my maps and location indicator properly, and my phone was supplying onx with my location of where to place the red dot on the maps?

Can you please explain why I need internet service when out in the field? What in the function of onxmaps requires the internet when "offline"? Am I wrong to believe that the onx app is running autonomously within my phone, and the phone's GPS capabilities provide my location? How does the function of the tracker option require the internet in any way? I do not have satellite internet service, and I can assure you that I was sufficiently far enough from any source of internet service accept satellite service, so I must say I'm having a hard time wrapping my head around my problem as being internet related. If I am wrong in my understanding of how onx works, please advise me, I'm always ready to learn something new, or at least better than I do currently.

As I ruminate over how events transpired today, it seems that the onx app may not have "booted up" properly initially (the first indication was it freezing on the initial screen shot of the two people, and never switching over to my map). The second indication was the tracker, and waypoint attempt, did not function. And thirdly, after a couple of hours, the final notice that onx had ceased functioning, and the request from the onx app, as to what it wanted me to do?

I had hoped that rebooting the app would have reset the parameters and allowed it to function properly, but it did not. I think if this happens again, I will not only close the app, but also turn my phone off and then back on to see if the phone "reset" will start everything fresh. Just my additional thoughts of the day.......
 

wapitibob

Senior Member
Joined
Feb 24, 2012
Messages
2,862
Location
Bend Oregon
You don't need internet when out in the field.. Most problems I have seen, except the missing layer bug, appear to be from people running onx with service then get to areas where that service becomes spotty. When that happens the phone continues to try to use service that isn't there and the app will appear to lock up as it waits.
They posted a new update late last week that will hopefully eliminate the layer bug and may fix issues you are having.
 
OP
M

MT-ED

Newbie
Joined
Aug 9, 2020
Messages
9
Hi Wapitibob, I just checked for the update (per the onx instructions) and it did not offer me an update, just an uninstall or open! Do you happen to know what the update version is? Thanks FWIW I've got ver.20.29.1 loaded
 

dioni.a.312

Senior Member
Joined
Mar 29, 2016
Messages
267
Mine has been not updating my location recently. I will hike around for quite a while and it will continue to show me immobile in one spot. It's super frustrating when you're trying to navigate hard to find trails that come and go frequently!!!!
 
Top